How To – Fix iPhone iOS 4.3.1 No Signal After Jailbreak + Unlock

A lot of people are experiencing problems after unlocking their iphones (after an iOS 4.3.1 Jailbreak), where it leaves them without having a signal on their phone.

The affected are listed:

ultrasn0w 1.2 baseband 06.15.00 on iPhone 3GS and 01.59.00 baseband on iPhone 4

Make sure you update to the latest version of ultrasn0w (which has recently been updated to version 1.2.1)

The problem is easily fixed by following the below tutorial:

Step 1: Open Cydia on your iPhone 4 or 3GS
ultrasn0w-fixer-for-ios-4.3 (1)
Step 2: Go to Manage->Sources
ultrasn0w-fixer-for-ios-4.3 (2)
Step 3: Now tap on “Edit”, then tap on “Add”
ultrasn0w-fixer-for-ios-4.3 (4)
ultrasn0w-fixer-for-ios-4.3 (5)
Enter the following repo
http://cydia.pushfix.info
Now tap on “Add Source”
Step 4: Tap on Done.
Step 5: Tap on Pushfix.info and install
ultrasn0w-fixer-for-ios-4.3 (6)
Step 6: After the installation Go to Pushfix.info again. Now scroll down and look for “Ultrasn0w fixer for 4.3.1” Tap on it. Install the package. It will ask you to reboot your device.
ultrasn0w-fixer-for-ios-4.3 (7)
ultrasn0w-fixer-for-ios-4.3 (8)
ultrasn0w-fixer-for-ios-4.3 (9)


22 comments

Write a comment
  1. john D
    john D 6 April, 2011, 01:03

    i have ATT.. i followed the steps above yet i dont get a reception

    Reply this comment
  2. PASCAL
    PASCAL 6 April, 2011, 02:07

    I TRY BUT DOESN’T FIX THE PROBLEM STILL NO SIGNAL….

    Reply this comment
  3. admin
    admin Author 6 April, 2011, 15:23

    what baseband are you guys on?
    Probably worth refirmwaring the phone and then rejailbreaking it, this time try it with sn0wbreeze.
    If again same problem after the jailbreak, apply the tut from this page and report back please.

    Reply this comment
  4. admin
    admin Author 6 April, 2011, 16:31

    Actually a new update to ultrasn0w will be released quite soon.
    The team is working on a fix right now, they are just testing it on different devices.

    Reply this comment
  5. admin
    admin Author 6 April, 2011, 16:31

    Also please remember that:
    Not supported basebands : 2.10.04 / 3.10.01 / 4.10.01

    Reply this comment
  6. Junfei
    Junfei 7 April, 2011, 05:42

    Thank you! I fixed my problem

    Reply this comment
  7. Thang
    Thang 8 April, 2011, 00:21

    Thanks for your posted, it works with my 3GS 4.3.1 baseband 06.15. If the system hanging while reboot, re-install cydia (I used redsnow 0.9.6cr9). And booted fine, installed T-mobile sim card and got signal after 1-3 mins. This is my 1st time I’m able unlocked my phone by myself.

    Reply this comment
    • admin
      admin Author 8 April, 2011, 10:33

      Very good Thang.
      Indeed if for some reason any of you get stuck in itunes mode, then use the fixrecover from tinyumbrella, I will be posting a tutorial on this later on today.

      Reply this comment
  8. BrianD
    BrianD 9 April, 2011, 00:00

    How can this be fixed if you used Pwnage

    Reply this comment
    • admin
      admin Author 9 April, 2011, 00:27

      Through PWnage you should have had the option to install cydia as well, so through cydia install ultrasn0w as well as the fix from this tutorial.

      One thing everyone should know though is that if you have jailbroken your phone and you are still getting a “no service” or no signal on your phone, then this is probably due to not having the phone activated.
      To activate it, you need to deactivate it first through redsn0w.
      This will make the phone go into an unactivated mode where you can only do emergency calls.
      Insert the original sim card of the carrier (e.g. if the phone is a registered t-mobile then insert a tmobile sim card in it), once done connect the iphone to the computer and activate it.
      Let it update the carrier settings if there are any updates.
      You can now remove the sim from the iphone and insert the different carrier sim and use it :)

      Obviously all of the above while already having ultrasn0w installed through cydia (without the fix) and if it doesnt work then install the fix from this tutorial.

      Reply this comment
      • BrianD
        BrianD 9 April, 2011, 03:59

        I had installed both when I posted, and am still having only single bar for signal strength. I have service and am able to make and receive call.

        Reply this comment
  9. Eben
    Eben 9 April, 2011, 07:28

    Hi
    I have been reading the comments here but still not really found out what to do.
    I have a factory unlocked Iphone from Hong Kong and the new 4.3.1 firmware and have just used PwnageTool to Jailbreak it. I now only have one bar of signal. I have reset all settings and tried changing sim cards and the phone still connects with what ever sim card I use but I only have one bar of signal.
    What is the logical thing to do now?
    Thanks in advance.
    Eben

    Reply this comment
  10. admin
    admin Author 10 April, 2011, 23:05

    Hi guys, as you many now know from the site news, the new ultrasn0w has been released, if you already have it installed then just upgrade/update it through cydia.

    http://www.smoothblog.co.uk/2011/04/10/ultrasn0w-121-released-fixes-431-signal-loss-bar-problems/

    Reply this comment
  11. averagecabbage
    averagecabbage 13 April, 2011, 17:28

    I am getting stuck on step 4 of this , it says insall pushfix.info, but how do I do that??I went under “P” and tried to install pushfix 2.0 but it won’t install, says no keys? do I have to purchase certificates? when I try to installultras0w fixer says modifications cannot be applied etc..?

    Thanks

    Reply this comment
    • admin
      admin Author 13 April, 2011, 18:53

      Did you add the source http://cydia.pushfix.info ?
      Once added, search for the ultrasn0w fixer package and install it.
      Make sure you have upgraded all packages that need upgrading in cydia.
      Key certs are asked for when downloading the package, if you are having that problem then its because it hasnt downloaded the package completely. Make sure that you are fully connected to the internet by wireless preferably.

      If ultrasn0w fixed is installed, remove it.
      remove ultrasn0w too.
      Reboot the phone
      Go into cydia
      Install ultrasn0w
      install the fix once again.
      Voala.

      Reply this comment
  12. Steve
    Steve 27 April, 2011, 21:44

    Hi, I installed pushfix.info and Ultrasn0w fixer for 4.3.1 does’t show up on the list. I need help I have no signal service

    Reply this comment
  13. Masóud
    Masóud 18 May, 2011, 11:38

    hi, i cant find Ultrasn0w fixer on the list, after added the source,
    i can se Youtube fix and t-mobile but not Ultrasn0w..
    help plz.
    thx in advance

    Reply this comment
    • admin
      admin Author 18 May, 2011, 13:33

      it wouldnt be there anymore since the new version of ultrasn0w was fixed with the issue, so make sure you have the latest version of ultrasn0w, if for some reason it doesnt ask you to update it, then that means that you have the latest version installed.

      Reply this comment
  14. EW
    EW 25 June, 2012, 02:46

    Do you have some where that I can send phone and get you guys to look at it. I still cant get service? Thanks for any help!

    Reply this comment

Write a Comment

Leave a Reply